Tesztek Android Google Apple Microsoft Samsung Huawei Nokia Linux Biztonság Tudomány Facebook Film
ga

Összeakadhat a Linux és a Vista SP1

2008.04.16. 15.17
Nem biztos, hogy tudják telepí­teni a Windows Vista első szervizcsomagját (SP1) azok a felhasználók, akik a Microsoft operációs rendszere mellett dual boot környezetben Linuxot is használnak a gépükön. A problémába azok futnak bele, akik a Vista meghajtótitkosí­tást (BitLocker) támogató változatai – ez az Enterprise és az Ultimate – mellé úgy pakolták fel a linuxos rendszert, hogy annak bootloaderét a Master Boot Recordba (MBR) telepí­tették.

A gondot az okozza, hogy az SP1 előfeltételének számí­tó egyik patch (KB935509) magát a windowsos bootloadert frissí­ti – í­rja az APCMag. Márpedig a nyí­lt forráskódú operációs rendszer – ha a felhasználó ezt a lehetőséget választja – éppen ezt szokta kicserélni saját programjára (Grub vagy Lilo). Mivel a patch telepí­tője megvizsgálja a rendszer bootfolyamatának integritását (beleértve az esetleges TPM chipet és az MBR-t is), abban az esetben, ha nem találja meg az eredeti bootloadert, leállí­tja az SP1 telepí­tését. Erre az ellenőrzésre azért van szükség, mert az szervizpakk frissí­ti a BitLocker szolgáltatást is – már azokban a Vista-verziókban, ahol ez elérhető –, és ennek támogatásához kell az ú bootloader.

Teljes cikk: ITcafe.hu