Tesztek Android Google Apple Microsoft Samsung Huawei Nokia Linux Biztonság Tudomány Facebook Videojáték Film
ga

Mac OS X buffer overflow

2010.01.11. 15.51
A SecurityReason egy biztonsági figyelmeztetőt adott ki, amelyben arra hívja fel a felhasználók figyelmét, hogy az Apple Mac OS X 10.5 / 10.6 (a régebbi verziók kétségesek) operációs rendszerei buffer túlcsordulási hibát tartalmaznak. A hiba a libc/gdtoa-t és a strtod(3) függvényt érinti. Kritikus hibáról van szó, ami ráadásul számos egyéb gyártó termékét is érinti, vagy érintette. Ide sorolható a három legnépszerűbb BSD disztribúció, egyes Mozilla termékek, az Opera, Google Chrome, KDE, Matlab és a Sony PS3 játékkonzolja. A hiba lehetőséget ad mind helyi, mind távoli támadásra.

A bejelentés itt olvasható.