Tesztek Android Google Apple Microsoft Samsung Huawei Nokia Linux Biztonság Tudomány Facebook Film
/ContentUploads/N6993/linux_meltdown_spectre.jpg

A Linux már védett a Meltdown és a Spectre sérülékenységgel szemben

2018.01.31. 08.14
Miután kiderült, hogy a Microsoft kénytelen letiltani a Meltdown és Spectre sérülékenység elleni javítást annak stabilitási problémái miatt, Linus Torvalds bejelentette a Linux rendszermag 4.15-ös verziószámmal ellátott kiadását, ami már igazi védelmet nyújt a sérülékenységekkel szemben.

Az Intel által publikált javítást erős szavakkal kritizáló Torvalds nem kapkodta el a végleges kiadást, 2011 óta ezen a verzión dolgoztak a legtovább – összesen 9 fejlesztői előzetesen át tesztelték és csiszolták, ráadásul időben 2 hetet csúsztak az eredeti tervekhez képest.

Bár az említett sebezhetőségek javítása a legfontosabb hír a 4.15-ös Linuxszal kapcsolatban, érdemes megemlíteni, hogy a kernel több olyan biztonsági funkcióval bővült, amik nagy mértékben javítják a platform biztonságát. Az AMD processzorokon már támogatott a Secure Encrypted Virtualization (SEV), amivel titkosított virtuális gépek futtatása válik lehetővé, az Intel processzorokon pedig elérhetővé vált a User Mode Instruction Prevention (UMIP), ami csökkenti a „privilege escalation” típusú támadások/sebezhetőségek kockázatát.

Forrás: eWeek
Összes hozzászólás